70 lines
1.9 KiB
Nix
70 lines
1.9 KiB
Nix
{ pkgs, ... }: {
|
|
home.packages = with pkgs; [
|
|
alsa-utils
|
|
];
|
|
|
|
home.file = {
|
|
"precision/fixmicrophone" = {
|
|
executable = true;
|
|
text = ''
|
|
# https://github.com/NixOS/nixpkgs/issues/294170
|
|
sudo ln -s /run/current-system/sw/bin/rm /bin
|
|
sudo ln -s /run/current-system/sw/bin/mkdir /bin
|
|
|
|
# https://discourse.nixos.org/t/dell-xps-13-9320-microphone-not-working/40932/3
|
|
sudo alsactl init
|
|
systemctl --user restart pipewire
|
|
'';
|
|
};
|
|
|
|
"precision/home" = {
|
|
executable = true;
|
|
text = ''
|
|
xrandr \
|
|
--output DP-4-3 --mode 3840x2160 --rate 30 --primary \
|
|
--output DP-4-1 --mode 3840x2160 --rate 30 --right-of DP-4-3 \
|
|
--output eDP-1 --off
|
|
i3-msg restart
|
|
'';
|
|
};
|
|
"precision/office" = {
|
|
executable = true;
|
|
text = ''
|
|
xrandr \
|
|
--output DP-2-2 --mode 3840x2160 --rate 30 --primary \
|
|
--output DP-2-1 --mode 3840x2160 --rate 30 --right-of DP-2-2 \
|
|
--output eDP-1 --off
|
|
i3-msg restart
|
|
'';
|
|
};
|
|
"precision/backward" = {
|
|
executable = true;
|
|
text = ''
|
|
xrandr \
|
|
--output eDP-1 --mode 1920x1200 \
|
|
--output DP-2 --mode 3840x2160 --rate 30 --primary --right-of eDP-1
|
|
i3-msg restart
|
|
'';
|
|
};
|
|
"precision/standalone" = {
|
|
executable = true;
|
|
text = ''
|
|
xrandr \
|
|
--output eDP-1 --mode 1920x1200 --primary \
|
|
--output DP-1 --off \
|
|
--output DP-2 --off \
|
|
--output DP-3 --off \
|
|
--output DP-4 --off \
|
|
--output DP-5 --off \
|
|
--output DP-2-1 --off \
|
|
--output DP-2-2 --off \
|
|
--output DP-2-3 --off \
|
|
--output DP-4-1 --off \
|
|
--output DP-4-2 --off \
|
|
--output DP-4-3 --off
|
|
i3-msg restart
|
|
'';
|
|
};
|
|
};
|
|
}
|